Migrate FileCabinet CS data to Onvio

This article provides guidelines and best practices to help you migrate your firm's FileCabinet CS data to Onvio.

Note: If you are moving files from another document management system into Onvio, see Move files into Onvio Firm Management from another document management system.

Considerations

Consider the following before you proceed with migration.

  • Is migrating all of your FileCabinet CS data the best option for your firm?

    If you do not have clients already set up in Onvio, they will be created when the FileCabinet CS data is migrated.

    If you have several years of historical FileCabinet CS data, you may want to store and access some of your older FileCabinet CS data locally and migrate only data from recent years into Onvio.

    If you decide to migrate only a certain number of years of data to Onvio, please note the following.

    • All CS application folders and recursive folders that fall within the designated time period will be migrated.
  • If any drawers in FileCabinet CS contain matching EINs or SSNs, only the first drawer that is migrated will exist in Onvio. The migration process will exclude any additional drawers with matching EINs or SSNs and those drawers will be listed in the Document_Upload_Exception_Report that is available when the migration results are displayed. We recommend that you merge duplicate drawers prior to conversion to ensure that all data is included.

    To include documents from a drawer that was not migrated for this reason, manually extract the documents from FileCabinet CS and manually upload them to a folder in Onvio that you designate within the primary Client ID.

  • If your firm licenses NetClient CS, you must store all NetClient CS documents in FileCabinet CS prior to migration.

    The migration tool does not process documents stored in NetClient CS; therefore, you will need to move any NetClient CS documents that you want to access in Onvio into FileCabinet CS prior to migration.

  • To include archived data in the migration, you must first restore it.
  • To include password-protected drawers in the migration, you must first remove all passwords on protected drawers that you want to be migrated.

    Note: After migration, these drawers will be viewable by any staff member who has access to Client Documents in Onvio.

  • If your firm uses UltraTax CS, we recommend that you export contact information for your clients from UltraTax CS to Onvio prior to migrating your FileCabinet CS client data. To do this, choose Utilities > Onvio integration > Populate Clients and Contacts from within UltraTax CS.
  • If the migration process is interrupted due to a connection issue or maintenance process, you may need to restart the process. (You won't need to include clients that were successfully migrated prior to the restart.) Therefore, we recommend that if you run the migration process overnight, you limit the number of drawers to a subset of all of your firm’s drawers.
  • You must install and use the FileCabinet CS migration tool to migrate your files from FileCabinet CS to Onvio. The FileCabinet CS Conversion utility is a separate feature that provides optimizing and reformatting options to improve the speed and performance of FileCabinet CS and is not used in the migration process.

Migration steps

Your firm must be licensed for Onvio with FileCabinet CS (version 2018.1.0 or higher) to be able to run the migration process from the File > Export to Onvio menu command.

Support: The FileCabinet integration license file is ZDXname.dat that should be in X:\WinCSI\Licenses.

  1. Verify that you have installed the latest version of FileCabinet CS and have installed the latest license files.

    Note: If you are working in the Virtual Office CS or Software as a Service (SaaS) environment—where the Migration Tool is integrated into the application—you can skip to step 4.

  2. Download the installation file.

  3. Locate the fcab_migration_installer.en_us.msi file on your computer, open the file, and follow the steps in the setup wizard to install the FileCabinet CS migration tool.
  4. In FileCabinet CS, choose File > Export to Onvio.
  5. In the window that opens, enter your Onvio credentials and click Continue.
  6. Choose the data location of the drawers that you want to migrate from the Data Location drop-down list.
  7. Highlight drawers in the Drawers available pane and click the Select button to move drawers to the right pane or click the Select All button to move all available drawers to the right pane.
  8. Optional: in the Focus group box, you can filter the drawers that appear in the Drawers available pane by marking the checkboxes for Active, Inactive, Defunct, or Previously Migrated Drawers.

    Note: By default, FileCabinet CS does not show previously migrated drawers in the Drawers available pane. Note that if you choose to migrate a drawer to Onvio that was previously migrated, you will overwrite any duplicate files for those clients in Onvio.

  9. Mark the appropriate checkboxes in the Options group box.

    Note: You can use these options together to choose a date range and then choose specific folders that you want to include within the selected date range.

    • Export documents from selected folders only: Mark this checkbox to open a screen in which you can choose to include all folders in a specified date range or to include specific folders.

      Note: You can re-open the dialog to make changes before continuing by clicking the Select Folders button.

    • Include Annotations: Mark this checkbox to retain all annotations in the migration process.

      Note: Any annotations that you include in the migration process become permanent components of their associated documents.

  10. Click the Continue button to start the migration process.

    Notes

    • The duration of the migration process will vary, depending on your firm's drawer sizes, the file sizes of documents in each drawer, and your firm's technology infrastructure; however, under ideal conditions, a single 50MB drawer that includes 30 documents should take between 8 to 10 minutes to migrate. You can print a Drawer list report to view detailed information about your firm's drawers.
    • If the migration process is stopped for any reason prior to completion, you may need to restart the process. Any drawers that were migrated will not appear in the drawer list when you restart the migration process.
    • You can view the information related to the status of the migration in Onvio
  11. When the migration process is complete, a Results dialog appears with information on how many drawers and files were extracted and uploaded as clients in Onvio. This dialog will also include a link to any reports generated from client or file exceptions.

    Notes

    • Reports can be found in c:\user\[[user name]]\Documents\FileCabinet
    • Virtual Office and SaaS users can access the reports through FileCabinet CS. Go to Object > Create from File. Browse to Documents\FileCabinet.
  12. Click OK. 

Notes

  • When you select more than one drawer for conversion, the conversion process skips any drawers that cannot be converted due to damaged data.
  • When a single drawer that contains damaged data is selected for conversion, you will be prompted to allow FileCabinet CS to extract and convert usable portions of the drawer data. Damaged portions of the drawer will not be converted, and this can result in the loss of documents. As part of this process, FileCabinet CS creates a copy of the original drawer files prior to conversion.
  • Drawers will be inaccessible during the export process.

After your migration is complete

Please note the following as you begin working with your data in Onvio.

  • Recurring folders appear differently in Onvio: You'll notice that data from any recurring folders that you had set up in FileCabinet CS appears differently in Onvio. In FileCabinet CS, recurring folders were displayed as a top-level folder with sub-folders for each year; in Onvio, the data will be organized at a single level with similar content separated by year. Show me.
    File structure differences
  • Linked documents that are migrated from FileCabinet CS to Onvio are no longer linked: Documents that exist in more than one folder in a FileCabinet CS drawer are linked. If you make changes to a linked document, all instances of that document are updated in FileCabinet CS. However, any changes that you make to previously linked documents in Onvio will not update multiple instances of that document in Onvio.
  • Some document names include double file extensions: When you print a document to FileCabinet CS, the document name includes the original extension in its name (for example: .xls, .pdf, .doc.), but the file is actually stored as an image in FileCabinet CS. During migration, these images are converted to PDF files with the original extension in the filename (Filename.xls.pdf, for example). Any embedded objects will retain their original filenames with a single file extension after migration.

The availability of some or all of these features depends on the applications your firm has licensed and the permissions your firm’s administrator has enabled for you.

Internal notes


For firms transitioning data from FileCabinet CS to Onvio, there are a few licensing considerations.

  • If they are not current on FileCabinet CS, submit a $0 EOR to extend the licenses to the next standard renewal date that is twelve months or more in the future.
  • If there is a licensing error in FileCabinet CS requesting a Terminal Server flag, submit an EMS ticket describing the error and requesting the Terminal Server be added. 

Was this article helpful?